Visa Developer Community

Highlighted

Issue MVisaQRParser with Swift 4.2 & above (XCode 10.2)

Facing issue while building in XCode 10.2 with swift 4.2.

Error: 

The following binaries use incompatible versions of Swift:

/Users/abc/Library/Developer/Xcode/DerivedData/abc-ekkearzjxndqyncigsrsexvysxlz/Build/Products/Debug-iphoneos/IDFC Bank.app/Frameworks/MVisaQRParser.framework/MVisaQRParser

Derived data has been cleared.

1 REPLY 1
Visa Dev Moderator

Re: Issue MVisaQRParser with Swift 4.2 & above (XCode 10.2)

Hey @AkankshaXebia,

 

To further investigate, please provide the following information:

1. End Point
2. Request Header
3. Request Body
4. Response Header (include the x-correlation-id)
5. Response Body

Using SoapUI, you can find the x-correlation-id in the Raw Tab of the response header.

 

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Tags (1)