Visa Developer Community

Issue MVisaQRParser with Swift 4.2 & above (XCode 10.2)

Facing issue while building in XCode 10.2 with swift 4.2.

Error: 

The following binaries use incompatible versions of Swift:

/Users/abc/Library/Developer/Xcode/DerivedData/abc-ekkearzjxndqyncigsrsexvysxlz/Build/Products/Debug-iphoneos/IDFC Bank.app/Frameworks/MVisaQRParser.framework/MVisaQRParser

Derived data has been cleared.

5 REPLIES 5
Visa Dev Moderator

Re: Issue MVisaQRParser with Swift 4.2 & above (XCode 10.2)

Hey @AkankshaXebia,

 

To further investigate, please provide the following information:

1. End Point
2. Request Header
3. Request Body
4. Response Header (include the x-correlation-id)
5. Response Body

Using SoapUI, you can find the x-correlation-id in the Raw Tab of the response header.

 

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Tags (1)
Regular Visitor

Re: Issue MVisaQRParser with Swift 4.2 & above (XCode 10.2)

Same issue here when building for iossimulator, but it works when building for iphoneos.

 

Is the framework compatible with simulators?

 

Regards,

Quentin

Tags (1)
Highlighted
Visa Dev Moderator

Re: Issue MVisaQRParser with Swift 4.2 & above (XCode 10.2)

Hey @Quentin,

 

I'll check with the Visa Direct product team, if this API is compatible with simulators and I'll let you know once I find out. 

 

Do you have any business relationship with Visa staff? Can you please let us know which country/region you are from?

 

Please see the "Working with Visa APIs" link to help you get started here - https://developer.visa.com/pages/working-with-visa-apis

 

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Newbie

Re: Issue MVisaQRParser with Swift 4.2 & above (XCode 10.2)

Please run below command in terminal to check the current version of swift for xcode

 

$swift --version

 

Apple Swift version 5.0 (swiftlang-1001.0.69.5 clang-1001.0.46.3)

Target: x86_64-apple-darwin18.6.0

 

For Xcode 10.2 , swift version is 5.0,  so you need to download corresponding SDK.

Newbie

Re: Issue MVisaQRParser with Swift 4.2 & above (XCode 10.2)

Yes, we provides SDK for both Device and Simulator.

 

Once you download SDK and unzip, you can see DEBUG and PRODUCTION version of zip.

 

DEBUG is for development and it will work on device and simulator.

PRODUCTION will work on device only and it is for App Store release version of app.