Visa Developer Community

Regular Visitor

Getting "9124 Incorrect credentials supplied"

I've follow the getting started guide many times.

Why am I always get response 9124 Incorrect credentials supplied from SOAPUI?

here is the request:

GET https://sandbox.api.visa.com/vdp/helloworld HTTP/1.1
Accept-Encoding: gzip,deflate
Authorization: Basic UlY4Q1lOVUNPWjUxMkUyWkpCTk0yMUpmX1VxYXYtTFBxajE2MG5ya09DUTJMVm90YzpIbjd3U1pPaThaMFQ1SUFFVGRCd2tYR05UazU=
Host: sandbox.api.visa.com
Connection: Keep-Alive
User-Agent: Apache-HttpClient/4.1.1 (java 1.5)

here's the response:

HTTP/1.1 401 Unauthorized
X-SERVED-BY: l55c007
X-CORRELATION-ID: 1496558011_961_74_l55c007_VDP_ARM
X-APP-STATUS: 401
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
Strict-Transport-Security: max-age=2592000;includeSubdomains
Cache-Control: no-cache, no-store, must-revalidate
Pragma: no-cache
Expires: Thu, 01 Jan 1970 00:00:00 GMT
Content-Security-Policy-Report-Only: default-src 'self' https://*.v.me https://*.visa.com;script-src 'self' 'unsafe-inline' 'unsafe-eval'  https://*.visa.com https://*.v.me;img-src 'self' https://*.v.me https://*.visa.com https://*.unica.com https://ad.doubleclick.net;style-src 'self' 'unsafe-inline' https://*.visa.com;object-src  https://*.v.me https://*.visa.com data:;report-uri /logging/logCSPReport;
X-Content-Security-Policy-Report-Only: default-src 'self' https://*.v.me https://*.visa.com;script-src 'self' 'unsafe-inline' 'unsafe-eval'  https://*.visa.com https://*.v.me;img-src 'self' https://*.v.me https://*.visa.com https://*.unica.com https://ad.doubleclick.net;style-src 'self' 'unsafe-inline' https://*.visa.com;object-src  https://*.v.me https://*.visa.com data:;report-uri /logging/logCSPReport;
X-WebKit-CSP-Report-Only: default-src 'self' https://*.v.me https://*.visa.com;script-src 'self' 'unsafe-inline' 'unsafe-eval'  https://*.visa.com https://*.v.me;img-src 'self' https://*.v.me https://*.visa.com https://*.unica.com https://ad.doubleclick.net;style-src 'self' 'unsafe-inline' https://*.visa.com;object-src  https://*.v.me https://*.visa.com data:;report-uri /logging/logCSPReport;
Content-Type: application/json;charset=UTF-8
Content-Length: 119
Date: Sun, 04 Jun 2017 06:33:32 GMT
Connection: keep-alive

{"responseStatus":{"code":"9124","severity":"ERROR","info":"","status":401,"message":"Incorrect credentials supplied"}}
5 REPLIES 5
Highlighted
Frequent Helper

Re: Getting "9124 Incorrect credentials supplied"

Hello,

 

while we are looking the issue in system log with X-CORRELATION-ID: 1496558011_961_74_l55c007_VDP_ARM, could you please confirm that you have followed the exact steps provided in getting started.

 

Thanks

Sanobar

Tags (1)
Highlighted
Regular Visitor

Re: Getting "9124 Incorrect credentials supplied"

Yes, I have followed the exact steps couple of times.

I've tried using VISA generated CSR, and my own CSR. Still the same.

 

I'm on Windows 10 by the way.

 

And for your information, I've already tried running the provided PHP sample code. It's the same result.

Highlighted
Regular Visitor

Re: Getting "9124 Incorrect credentials supplied"

And for your information, I've already tried running the provided PHP sample code. It's the same result.
Highlighted
Regular Visitor

Re: Getting "9124 Incorrect credentials supplied"

anyone?
Highlighted
Dabbler

Re: Getting "9124 Incorrect credentials supplied"

Hello,

 

I am wondering if you ever got this issue resolved for you.

Thanks,