Visa Developer Community

Highlighted
Regular Visitor

400 Bad Request For Hello World

HI Team,

 

I am getting 400 Bad Request when trying Hello World API from Our Middleware tool. It works fine in SOAP UI. Could you please let us know if we need to take any other setps to call the API from Middleware?

 

I double checked the userid and password sending as basic authentication in HTTP Headers

Do we need to send as userid and password as preemptiveAuth in Http Header ?

 

Error Message:

{
"responseStatus": {
"status": 400,
"code": "9124",
"severity": "ERROR",
"message": "Expected input credential was not present",
"info": ""
}
}

 

Thanks

5 REPLIES 5
Helper

Re: 400 Bad Request For Hello World

I'm also facing the same issue. Have you resolved? Could you please let me know

Visa Dev Moderator

Re: 400 Bad Request For Hello World

Hi @venkat98,

 

Please refer to this community forum post to resolve the issue - https://community.developer.visa.com/t5/General/Always-getting-quot-Expected-input-credential-was-no...

 

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Helper

Re: 400 Bad Request For Hello World

No Luck. I'm struggling badly to resolve this issue.

 

Figured out few, check below actions, that might help

  • Have you managed to connect to VISA using SOAP UI? 
  • If Yes, try configure SOAP UI with the key store (.jks) not the p12. This clarifies your JKS conversion/creation
  • Make sure you send a request with TLSv1.2
  • To enable the log use "-Djavax.net.debug=all" - Java Log

Wish you good luck. Thanks

Visa Dev Moderator

Re: 400 Bad Request For Hello World

Hi @venkat98,                             

 

Are you still experiencing an issue? Can you please let me know what region you are from?

 

 

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Visa Dev Moderator

Re: 400 Bad Request For Hello World

Hi @ganeshkaki,

 

Are you still experiencing an issue? Are you having an issue with SoapUI?

 

To further investigate, please provide the following information:

1. End Point
2. Request Header
3. Request Body
4. Response Header (include the x-correlation-id)
5. Response Body

Using SoapUI, you can find the x-correlation-id in the Raw Tab of the response header.

 

 

 

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana