Visa Developer Community

Highlighted
Newbie

Test QuestionProblems with Flexibile Token API ???????

I have set up a Project on Visa Developer Center, and I have API keys generated for use in the project. I am trying to test the Flexible Token API - https://developer.visa.com/capabilities/cybersource/reference#cybersource__cybersource_flex_api but I get an error when put my API Key into the call to Generate a Key referenced at:

 

https://developer.visa.com/capabilities/cybersource/reference#cybersource__cybersource_flex_api 

 

Which, according that doco is a Post to: 

 

3 REPLIES 3
Visa Dev Moderator

Re: Test QuestionProblems with Flexibile Token API ???????

Hi @Gondupaul,

 

The CyberSource Secure Acceptance Flexible Token v1 APIs was deprecated, therefore, you will not be able to use the Flex API. You will need to move to v2 CyberSource Rest APIs going forward. I have provided the link to the v2 CyberSource APIs below.
 
CyberSource Payments REST API
https://developer.visa.com/capabilities/cybersource/reference#cybersource__cybs_payments_v2

 

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Re: Test QuestionProblems with Flexibile Token API ???????

Hello Dianna,

 

Hope you are doing well. I am currently having struggle of tokenizng card, and it is returnung tokenization error , as I have read  thread you are giving solution to use v2 of cybersource. I just want to confirm, Cybersource secure acceptance flex token v1 is depreceated? and by using v2 cybersource payment , the card detials for this is already secured? I have attached screen error I encounter . Thank you so much

 

Screen Shot 2019-02-01 at 10.42.36 PM.png

Visa Dev Moderator

Re: Test QuestionProblems with Flexibile Token API ???????

Hi @DaVinceCoder,

 

Your understanding is correct, flex token v1 is deprecated. For questions about CyberSource API functionality please contact the CyberSource Support team directly using the phone number provided below.

 

CyberSource Support
800-709-7779

                             

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana