Visa Developer Community

Regular Visitor

"No Groups are configured for the requested Business Application ID" Merchant Locator API

Hi, to use the Visa API I followed the Get Started documentation given in https://developer.visa.com/guides/vdpguide#create-your-first-app. Tested the credentials with SoapUI GUI. While trying to query the VISA API's using the documentation provided for each API I am able to run the "Locate ATM API" which giving same results compare with the come provided in the browser query embeded in the documentation page with status {u'statusDesc': u'Visa ATM Locator Svc-Success', u'statusCode': u'CDI000'}. But while trying to use the "Merchant Locatotr API" and "Merchant Search API" though its responding with status code 200. But the content status {u'statusDescription': u'No Groups are configured for the requested Business Application ID', u'statusCode': u'CDI096'}". I am using python 2.7.10 and performing the API call with "requests" module following the Sample code for Two Way (Mutual) SSL given in the Get Started documentation.

 

The similar situation I am facing for the Merchant Search API too.

 

I created a GITHUB issue on Spetember 2016 but did not heard back anything yet:

https://github.com/visa/SampleCode/issues/27 

 

Any suggestion will be highly appreciated.

5 REPLIES 5
Community Manager

Re: "No Groups are configured for the requested Business Application ID" Merchant Locator

Hi Sayan,

 

I am looking into this for you, I will get shortly.

 

Thank you,

Ricardo

Regular Visitor

Re: "No Groups are configured for the requested Business Application ID" Merchant Locator

Thanks a lot Ricardo.

Regular Visitor

Re: "No Groups are configured for the requested Business Application ID" Merchant Locator

Hi Ricardo,

 

Thanks a lot for yopur qucik response. But Still am not able to make the API work.  The error statement only changed from  "No Groups are configured for the requested Business Application ID"  to “Internal Application Error” // “Internal server error”. I tried to use the request tab in the documentation website (https://developer.visa.com/products/merchant_locator/reference#merchant_locator__merchant_locator) with the arguments provided whoch resuklted in "status": "statusDescription": "Internal Application Error"statusCode": "CDI082"

Alos, I tried to call the API with 

VISA Miami address to find a Starbucks  with a 5 Mile distance as the nearest Starbucks is in less than 2 miles. Please see the attached Google Map.

    "merchantName": "Starbucks",

    "merchantCountryCode": "840",

    "latitude": "25.779014",

    "longitude": "-80.302682",

    "distance": "5",

    "distanceUnit": "M"

 

which result in "Internal server error" (Code: 9002).

Highlighted
Regular Visitor

Re: "No Groups are configured for the requested Business Application ID" Merchant

Is there any update on this case? I'm seeing the same problem.
I can establish connection to sandbox api but using the request from an example (https://developer.visa.com/products/merchant_locator/reference#merchant_locator__merchant_locator), I see:
"status": {
"statusDescription": "Internal Application Error",
"statusCode": "CDI082"

New Contributor

Re: "No Groups are configured for the requested Business Application ID" Merchant

I am also seeing the same thing, it's marked as resolved but I don't see a resolution.