Visa Developer Community

Highlighted
Helper

Reverse Funds

I successfully called the ReverseFunds API and I think i properly passed the required parameters needed but somehow it throws me an error of "API Error. Please contact your visa representative". Can someone please enlighten me about this ?

 

Thanks!

5 REPLIES 5
Community Manager

Re: Reverse Funds

Hi Reign,

Can you share a screenshot of your call?

 

I'm looking into this.

 

Thank you,

Ricardo

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.
Helper

Re: Reverse Funds

Hi Ricardo,

Here are the SS that you were asking. 

 

parameters.png

 

ExceptionError.png

ReturnError.png

As you can see the values in the json strings are from the example visa provided. So I really don't know what's wrong with it.

 

Thanks! Hope this help.

Re: Reverse Funds

Hello Reign

 

Please check that you send unique value in `x-correlation-id` or don't send it at all.

Community Manager

Re: Reverse Funds

Hi Reign,

Did you get this resolved?

 

If not, please make sure to use the below values for Acquiring BIN and System Trace audit number correctly wherever it appears in the payload.

 

Sample working payload:

{
"systemsTraceAuditNumber" : "897825",
"retrievalReferenceNumber" : "330000550000",
"localTransactionDateTime" : "${LocalTransactionDate}",
"acquiringBin" : "408999",
"acquirerCountryCode" : "608",
"senderPrimaryAccountNumber" : "4895100000055127",
"senderCardExpiryDate" : "2015-10",
"senderCurrencyCode" : "USD",
"amount" : "24.01",
"transactionIdentifier" : "381228649430011",
"originalDataElements" : {
"systemsTraceAuditNumber" : "897825",
"transmissionDateTime" : "2021-10-26T21:32:52",
"acquiringBin" : "408999",
"approvalCode" : "20304B"
},
"cardAcceptor" : {
"name" : "Visa Inc. USA-Foster City",
"terminalId" : "365539",
"idCode" : "VMT200911026070",
"address" : {
"state" : "CA",
"county" : "San Mateo",
"country" : "USA",
"zipCode" : "94404"
}
},
"pointOfServiceData" : {
"panEntryMode" : "90",
"posConditionCode" : "00",
"motoECIIndicator" : "0"
},
"pointOfServiceCapability" : {
"posTerminalType" : "4",
"posTerminalEntryCapability" : "2"
}
}

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.
Helper

Re: Reverse Funds

Ah yes I figured out what's wrong with the code. The culprit is the acquiring bin but for some reason I thought the error would be bad request since I pass a wrong parameters. Anyway, Thanks for the help. Cheers!