Visa Developer Community

Regular Visitor

generalinquiry API not working

Hi,

I'm trying to call generalinquiry API with the following request body shows below in log, API return status as 500. It has been working fine in last couple of days before.

[INFO ] 2019-01-18 07:00:32.406 [https-jsse-nio-443-exec-6] VisaAPIClient - hour 7
[INFO ] 2019-01-18 07:00:32.406 [https-jsse-nio-443-exec-6] VisaAPIClient - https://sandbox.api.visa.com/paai/generalattinq/v1/cardattributes/generalinquiry/
[INFO ] 2019-01-18 07:00:32.406 [https-jsse-nio-443-exec-6] VisaAPIClient - URI: https://sandbox.api.visa.com/paai/generalattinq/v1/cardattributes/generalinquiry/
[INFO ] 2019-01-18 07:00:32.406 [https-jsse-nio-443-exec-6] VisaAPIClient - GET General Attributes
[INFO ] 2019-01-18 07:00:32.407 [https-jsse-nio-443-exec-6] VisaAPIClient - RequestBody: {
  "primaryAccountNumber" : "4895070000003551"
}
[INFO ] 2019-01-18 07:00:43.100 [https-jsse-nio-443-exec-6] VisaAPIClient - HttpResponseProxy{HTTP/1.1 500 Internal Server Error [Server: Apache, X-SERVED-BY: l73c002, X-CORRELATION-ID: 1547794800_293_87_l73c002_VDP_ARM, X-APP-STATUS: 500, X-Frame-Options: SAMEORIGIN, X-XSS-Protection: 1; mode=block, X-Content-Type-Options: nosniff, Strict-Transport-Security: max-age=2592000;includeSubdomains, Cache-Control: no-cache, no-store, must-revalidate, Pragma: no-cache, Expires: -1, Content-Type: application/json;charset=UTF-8, Content-Length: 94, X-Cnection: close, X-Cnection: close, Date: Fri, 18 Jan 2019 07:00:10 GMT, Connection: close] ResponseEntityProxy{[Content-Type: application/json;charset=UTF-8,Content-Length: 94,Chunked: false]}}
[INFO ] 2019-01-18 07:00:43.100 [https-jsse-nio-443-exec-6] VisaAPIClient - invalid card
[INFO ] 2019-01-18 07:00:43.100 [https-jsse-nio-443-exec-6] VisaAPIClient - Status value is   500

I also tried to check this API url following link https://developer.visa.com/capabilities/paai/reference#paai__gaai__v1__generalinquiry
I'm not sure what i have missed.

 

Thank you,

Hari kb

1 REPLY 1
Frequent Helper

Re: generalinquiry API not working

Hi Hari,

 

Thanks for reaching out. We are aware of this issue and our team is currently working on it and we expect this to be resolved soon. Will keep you posted.

 

Thanks,

Jai