Visa Developer Community

Regular Visitor

Visa Checkout framework on XCode 9

Hi,

 

I use Visa checkout framework on my project, and recently, in order to support the upcoming iPhone X, I updated my XCode to the newest version 9, but now I'm getting an error while compiling that is caused by the Visa checkout framework, it says "Module compiled with Swift 3.1 cannot be imported in Swift 4.0" I don't know if someone here have a workaround to solve this error

 

thanks!

Tags (2)
1 REPLY 1
Highlighted
Regular Visitor

Re: Visa Checkout framework on XCode 9

XCode 9 support swift versions 3.2/4.0 and it's application binary interface is not compatible with older versions of swift, leading to compatibility error. The developer portal will be updated with XCode 9 built binaries and projects built in XCode 9 should be using these binaries. You can reach out to one of Visa's account managers to get an early access to these binaries.