Re: Tokenize card issue

jbonglo
Helper

Tokenize card issue

Whenever we invoke the tokenize card API:

/cybersource/payments/flex/v1/tokens

 we get a tokenization failed error.

 

On checking Cybersource transactions (at https://ebc2test.cybersource.com/ebc2), we see it fails because of the issue below:

 

This gateway does not support ics pay subscription: (null=integrated):vdcdps,smartpay

Anyone experienced this issue before? How did you resolve it? Thanks in advance.

3 REPLIES 3
jvenkata
Community Moderator

Re: Tokenize card issue

Hi,

 

Thanks for your inquiry. We are looking into this issue. We will keep you posted soon with the updates.

 

Thanks,

Jai

jbonglo
Helper

Re: Tokenize card issue

Any update on this?

DianaTran-Yee
Visa Developer Support Specialist

Re: Tokenize card issue

Hi @jbonglo,

 

Please note, that the CyberSource Secure Acceptance Flexible Token v1 APIs was deprecated, therefore, you will not be able to use the Flex API. You will need to move to v2 CyberSource Rest APIs going forward. I have provided the link to the v2 CyberSource APIs below.
 
CyberSource Payments REST API - https://developer.visa.com/capabilities/cybersource/reference#cybersource__cybs_payments_v2




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.