2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File api

Solved! Go to solution
hempreet
Helper

2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File api

I have set the certificate and the key in certificates section in postman and given the username and password in for the basic authentication. Now when I try to hit hello world endpoint to test, its working fine but when the same I try to hit Card-On-File Data Service API, it gives below error:

{
    "responseStatus": {
        "status"400,
        "code""9125",
        "severity""ERROR",
        "message""Expected input credential was not present",
        "info"""
    }
}
16 REPLIES 16
jenn_kh
Community Moderator

Re: 2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File

Thank you for reaching out, @hempreet! An agent will get back to you with more information as soon as possible. In the meantime, if any community member knows the solution, please feel free to share here! -Jenn

hempreet
Helper

Re: 2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File

Ok @jenn_kh , thanks for acknowledging and helping with the issue.

DianaTran-Yee
Visa Developer Support Specialist

Re: 2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File

Hi @hempreet,

 

For further investigation of the error, please provide the following information:

1. Endpoint
2. Request Header
3. Request Body
4. Response Header (include the x-correlation-id)
5. Response Body

Using SoapUI, you can find the x-correlation-id in the Raw Tab of the response header.




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

hempreet
Helper

Re: 2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File

Hi @DianaTran-Yee , Please find below the details as required:

 

1. Endpoint: https://sandbox.api.visa.com/cofds-web/v1/datainfo

2. Request Header: request headers.png
3. Request Body: 

{
  "requestHeader": {
    "requestMessageId""6da6b8b024532a2e0eacb1af58581",
    "messageDateTime""2019-02-35 05:25:12.327"
  },
  "requestData": {
    "pANs": [
      4072208010000000
    ],
    "group""STANDARD"
  }
}


4. Response Header (include the x-correlation-id): 

response headers.png
5. Response Body:

{
    "responseStatus": {
        "status"400,
        "code""9125",
        "severity""ERROR",
        "message""Expected input credential was not present",
        "info"""
    }
}
 
 
Actually, I used postman for hitting the url and not soapui so got little bit confused.
 
Thanks and regards.
Hempreet Singh
gellany
Occasional Visitor

Re: 2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File

i have same issue and notes of @DianaTran-Yee not help , we want to root know cause of this issue because i think this issue related to backedend of server , am using python and sucees with hello wolrd but failure in https://developer.visa.com/capabilities/card-on-file-data-inquiry/reference#tag/Card-On-File-Data-Se...
cathy2981
Community Moderator

Re: 2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File

We appreciate you bringing this to our attention, @gellany . We have let our team know and an agent will follow up with any information. -Cathy

hempreet
Helper

Re: 2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File

@cathy2981, ok great. Thanks. for acknowledging.
hempreet
Helper

Re: 2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File

Ohh Ok. We will try to find out the possible solutions.

clin15
Helper

Re: 2 way SSL connection works fine for Hello world api but got error trying to hit the Card-On-File

hey @hempreet , @gellany 

The API requires MLE verification.so make the api call with MLE and your good to go. Had faced the same problem today however resolved it..