Visa Developer Community

Highlighted
Newbie

Issuer SDK for QR parsing not compatible with Swift 5.1.3/ Xcode 11.3

MVisaQRParser.framework (i.e. QRParserSDK-3.0.0-5.1) is working successfully for the Xcode 11.1 as its swift version is 5.1.

But once I update my Xcode with 11.3. it's stopped working for my application.

Please find the issue from the screenshot and Xcode version from the attached images.
Main issueMain issue

 

Xcode versionXcode version

 


Issue: 

Module compiled with Swift 5.1 cannot be imported by the Swift 5.1.3 compiler




5 REPLIES 5
Highlighted
Visa Dev Moderator

Re: Issuer SDK for QR parsing not compatible with Swift 5.1.3/ Xcode 11.3

Hey @GaurangInd,

 

I have logged case #INC8883214 for the engineering team to investigate the issue. Can you please copy and paste the full error response and error message that you're getting? 

 



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Highlighted
Visa Dev Moderator

Re: Issuer SDK for QR parsing not compatible with Swift 5.1.3/ Xcode 11.3

Hey @GaurangInd,

 

Happy New Year! We haven't heard from you recently. Can you please copy and paste the full error response and error message that you're getting? 

 



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Highlighted
Visa Dev Moderator

Re: Issuer SDK for QR parsing not compatible with Swift 5.1.3/ Xcode 11.3

Hey @GaurangInd,

 

I'd like to help resolve your issue, however, to continue can you please provide the transaction details for this issue like a CR,RRN? This looks like a SDK issue.

 

 



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Visa Dev Moderator

Re: Issuer SDK for QR parsing not compatible with Swift 5.1.3/ Xcode 11.3

Hey @GaurangInd,

 

I've tried reaching out to you three times and I haven't heard back from you. Since that's the case, I'll be closing out case INC8883214. Feel free to reach back out to us and let us know if you need help with anything else.

 



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana

Highlighted
Regular Visitor

Re: Issuer SDK for QR parsing not compatible with Swift 5.1.3/ Xcode 11.3


@DianaTran-Yee wrote:

Hey @MCDVOICE

 

I've tried reaching out to you three times and I haven't heard back from you. Since that's the case, I'll be closing out case INC8883214. Feel free to reach back out to us and let us know if you need help with anything else.

 


I'd like to help resolve your issue, however, to continue can you please provide the transaction details for this issue like a CR,RRN? This looks like a SDK issue.