Visa Developer Community

Highlighted
Regular Visitor

MVisaQRParser 1.6.1 - Issues Compiling App Built with Swift 4.0.2 (XCode 9.1)

Hi,

Looks like the module for mVisa (MVisaQRParser 1.6.1 - iOS SDK) is not compatible with XCode 9.1.

Can we get a fix for this?

Thanks.

 

Opel.

4 REPLIES
Community Manager

Re: MVisaQRParser 1.6.1 - Issues Compiling App Built with Swift 4.0.2 (XCode 9.1)

Hi Opel - thanks for letting us know. I'm checking with our product team on this, and will get back to you in a few days.

Thanks

Marty

Visa Developer Team

Community Manager

Re: MVisaQRParser 1.6.1 - Issues Compiling App Built with Swift 4.0.2 (XCode 9.1)

Hi - new SDKs (version 1.8.0, for ios and android) have been posted to the documentation page. This should fix your issue.

Thanks

Marty

Visa Developer Team

Regular Visitor

Re: MVisaQRParser 1.6.1 - Issues Compiling App Built with Swift 4.0.2 (XCode 9.1)

Hi Marty,

 

I am still getting the same error?

 

I am also unable to run the sample app.

 

regards.

 

Screen Shot 2017-11-16 at 7.23.36 PM.pngScreen Shot 2017-11-16 at 7.22.10 PM.png

Newbie

Re: MVisaQRParser 1.6.1 - Issues Compiling App Built with Swift 4.0.2 (XCode 9.1)

Hi,

Xcode 9.1 (swift 4.0.2) is launched recently and we are under testing phase for mvisa sdk.

We will launch mvisa sdk swift 4.0.2 in next release around mid Dec.

 

Please use Xcode 9.0 and mVisa SDK swift 4.0 until, we release mVisa SDK swift 4.0.2

 

Regards and Thanks,

Khagesh Patel