Visa Developer Community

Highlighted
Regular Visitor

Issuer SDK for QR parsing not compatible with Swift 3.2/4.0

I'v successfully added your issuer SDK for QR parsing (version 1.5.2 for swift 3.1) to my IOS App. However we're upgrading all our apps to Swift 4.0 and your SDKs currently do not support Swift 3.2/4.0. Do you mind compiling a new swift version that is compatible with Swift 3.2/4.0. 

4 REPLIES 4
Highlighted
Frequent Helper

Re: Issuer SDK for QR parsing not compatible with Swift 3.2/4.0

Hello,

unfortunately, it is not on the roadmap in the near future. I am still sending your request to the product team. 

 

Thanks

Sanobar

Tags (2)
Highlighted
Regular Visitor

Re: Issuer SDK for QR parsing not compatible with Swift 3.2/4.0

Hi Sanobar,
iOS has a high adoption rate, and Apple just released iOS 11; to develop for this version you need Apple's latest development environment - Xcode 9 which Only supports Swift 3.2 / 4.0
If the mVisa Issuer SDK for QR parsing is not Upgraded to be compatible with Swift 3.2 / 4.0 then integrating it into third party apps will continually decline.
Kindly support your third party developers by add this to your most immediate road map.

With Thanks,
Joshua.

Highlighted
Regular Visitor

Re: Issuer SDK for QR parsing not compatible with Swift 3.2/4.0

Hi Sanobar,

 

Your response was really quick.

 

I find myself in the same dilenma - XCode 9 with swift 3.2/4.0 and I am unbale to use your SDK. I have switched to the MasterCard SDK - a beta was released in less thank six hours following the official release of XCode 9 and iOS 11. It's been fun so far, although I had to review my design as my original implementation was tighlty coupled with the Visa SDK.

 

Your decision not to upgrade your SDK means developers who continue to use you API may not be able to fully implement NFC support. Besides, developers who stcik with you will not be able to upgrade their apps to take advantage of te new features on Swift and the iOS api.

 

As stated earlier, I have moved on with the MasterPass SDK, but you may need to rethink your stance on this if you wish to remain competitive in this space.

 

Thanks.

 

Okechukwu Opel Agufuobi

Mobile Solutions Analyst | Developer

Zenith Bank Plc

Highlighted
Regular Visitor

Re: Issuer SDK for QR parsing not compatible with Swift 3.2/4.0

Hi Sanobar,
Many Thanks to the Visa Dev Team; we now have an update to the API (version 1.6.1)
However, Kindly help communicate the need to maintain iOS library's dependencies via Cocoapod.

This will save us a lot of headache integrating libraries into our apps. We will only need to change version number in our pod file.
With Regadrds,

Joshua.