400Bad Request in testing https://sandbox.api.visa.com/vdp/helloworld

400Bad Request in testing https://sandbox.api.visa.com/vdp/helloworld

am trying to test connect to visa via postman

i follow up https://community.developer.visa.com/t5/Two-way-SSL-X-Pay-Token/How-to-run-the-Hello-World-API-with-... and it is give me resonse as shown

{
"responseStatus": {
"status": 400,
"code": "9123",
"severity": "ERROR",
"message": "Expected input credential was not present",
"info": ""
}
}Screenshot 2023-07-13 at 10.38.18 AM.png
6 REPLIES 6
root
Regular Visitor

Re: 400Bad Request in testing https://sandbox.api.visa.com/vdp/helloworld

Are you testing in cert or sandbox? URL in the screenshot says cert. Also make sure the certificate configured is correct.

Re: 400Bad Request in testing https://sandbox.api.visa.com/vdp/helloworld

yes i take the configration as shown

Screenshot 2023-07-13 at 11.35.10 AM.png

i downlod the certifacte and implent it in

Screenshot 2023-07-13 at 11.36.51 AM.png

 

 

root
Regular Visitor

Re: 400Bad Request in testing https://sandbox.api.visa.com/vdp/helloworld

You should be adding the "Client Certificate" instead of the CA cert.

See "Step 2 - Configure 2-Way (Mutual) SSL" of the guide:

https://community.developer.visa.com/t5/Two-way-SSL-X-Pay-Token/How-to-run-the-Hello-World-API-with-...

Re: 400Bad Request in testing https://sandbox.api.visa.com/vdp/helloworld

where i can find Client Certificate"
could you help me with a screen shot from your device
root
Regular Visitor

Re: 400Bad Request in testing https://sandbox.api.visa.com/vdp/helloworld

The certificate needs to be setup in the developer portal.

 

Look at the section "How to get Credentials" https://community.developer.visa.com/t5/Two-way-SSL-X-Pay-Token/How-to-run-the-Hello-World-API-with-...

 

Additional resource:

https://developer.visa.com/pages/working-with-visa-apis/two-way-ssl

 

API_Managers
Visa Developer Support Specialist

Re: 400Bad Request in testing https://sandbox.api.visa.com/vdp/helloworld

Hi @ayagaidi1995,

 

It appears that you're a Certification client testing in the Certification environment, hence, please send an email to developer@visa.com and let them know the error you're facing and the region you are from. An API Specialist from your region will be assigned to help you. 




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.