Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

KJG
Helper

Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

Hello Diana,

Has there be any progress in resolving the this test data issue?

thanks

Kevin

DianaTran-Yee
Visa Developer Support Specialist

Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

Hi @KJG,

 

I've reached out to the engineering team for an update, so once I receive one I will definitely reach out to you and let you know.

 




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

DianaTran-Yee
Visa Developer Support Specialist

Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

Hi @KJG,

 

The test data does not work because it's masked. We're making progress on our end, as we're currently working on updating the DCAS Test Data.

 

I'll reach out to you with an update once I get one.




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

DianaTran-Yee
Visa Developer Support Specialist

Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

Hi @KJG,

 

We would like to setup a troubleshooting phone call with you. Can you please provide us with the best phone number to reach you at, the country and region you will be calling from, and some available time slots for a phone call? Please indicate the time zone that you are calling from as well, so we can find a representative to call you at during the time that you are available.

 

 

 




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

DianaTran-Yee
Visa Developer Support Specialist

Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

Hi @KJG,

 

Please check  your DCAS project dashboard for recent Test Data updates. Can you please try to test again to see if you get successful results for the debitcardinquiry in sandbox? 

 

I tested with my project Test Data and I was able to achieve successful results. Please see below for my request and response payload. I've also included a SoapUI screenshot of the successful 200 OK that was received. 

 

Request

{
"directDebitAccountNumber": "4514787821345017",
"routingNumber": "59831111113",
"cardholderName": {
"lastName": "DADE",
"firstName": "JACK"
}
}

 

Response

HTTP/1.1 200 OK
Server: nginx
Content-Type: application/json
Content-Length: 569
X-SERVED-BY: l55c012
X-CORRELATION-ID: 1563311856_270_208257870_l55c012_VDP_WS
X-Backside-Transport: OK OK,OK OK
Cache-Control: no-cache ,no-cache, no-store, must-revalidate
Pragma: no-cache
Expires: -1
X-OPNET-Transaction-Trace: a2_3b7b1e5d-3297-48ff-b660-cdbdc1821ffb-6344-2394
Correlation-ID: 882415f3-0430-45e2-8deb-020c4e96d087
X-Powered-By: ASP.NET
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
Content-Security-Policy: default-src 'self'; script-src 'self' 'unsafe-inline'; style-src 'self' 'unsafe-inline';
X-Global-Transaction-ID: 2046219949
X-APP-STATUS: 200
Strict-Transport-Security: max-age=2592000;includeSubdomains
Date: Tue, 16 Jul 2019 21:17:36 GMT
Connection: keep-alive

{"resource":{"debitCards":[{"primaryAccountNumber":"4514780782134512","sequenceOnCard":"1","expirationDate":{"mm":"01","yy":"99"},"activationStatus":"ACTIVE","cardStatus":"OK","shouldCaptureCard":true,"cardholderName":{"firstName":"John","lastName":"Doe","middleName":null,"title":null,"suffix":null},"cardholderAddress":{"addressLine1":"123 N Street","addressLine2":null,"addressLine3":null,"city":"SomeTown","postalCode":"90210","region":"CA","country":"840"},"clientUnqiueId":null}]},"processingTimeInMs":31,"receivedTimestamp":"2019-07-16 21:17:36.391","errors":[]}

 

20190716 DianaTranYee debitcardinquiry200ok.png

 

 




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

DianaTran-Yee
Visa Developer Support Specialist

Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

Hi @KJG,

 

Can you please confirm if your issue is resolved? If so, I'll close your ticket as resolved. Thanks!

 




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

DianaTran-Yee
Visa Developer Support Specialist

Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

Hi @KJG,

 

I haven't heard back from you so I'll be closing your ticket as resolved. You are welcome to contact us if you have further issues or if you'd like to re-open this ticket. Thanks!

 




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

DianaTran-Yee
Visa Developer Support Specialist

Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

Hi @KJG,

 

To follow up, for information on Visa Developer Error Codes please navigate to this page - https://developer.visa.com/pages/visa-developer-error-codes

 

Payload and URI Error Codes

404 Not Found error table.png

 




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

KJG
Helper

Re: Debit Card Inquiry in sandbox using test data always errors with "No Card Found"

Thanks Diana,

 

I used the "API Reference" links for the request and am getting no card or cards found for multiple requests sent using SOAPUI

https://sandbox.api.visa.com/dcas/cardservices/v1/cards/{cardId}/cardstatus

https://sandbox.api.visa.com/dcas/cardinquiry/v1/accounts/debitcardinquiry

Here is the request information with authorization masked

 

1. End Point 

https://sandbox.api.visa.com/dcas/cardinquiry/v1/accounts/debitcardinquiry
2. Request Header

POST https://sandbox.api.visa.com/dcas/cardinquiry/v1/accounts/debitcardinquiry HTTP/1.1
Accept-Encoding: gzip,deflate
Content-Type: application/json
Authorization: Basic ##################################################
Accept: application/json
Content-Length: 82
Host: sandbox.api.visa.com
Connection: Keep-Alive
User-Agent: Apache-HttpClient/4.1.1 (java 1.5)
3. Request Body

{
"directDebitAccountNumber": "4XXXXXXXXXX26006",
"routingNumber": "598XXXXXX06"
}
4. Response Header (include the x-correlation-id)

HTTP/1.1 404 Not Found
Server: nginx
Content-Type: application/json
Content-Length: 130
X-SERVED-BY: l73c015
X-CORRELATION-ID: 1559042251_041_1358076184_l73c015_VDP_WS
X-Backside-Transport: FAIL FAIL,FAIL FAIL
Cache-Control: no-cache ,no-cache, no-store, must-revalidate
Pragma: no-cache
Expires: -1
X-OPNET-Transaction-Trace: a2_c682bcf8-28c2-45af-96bd-ace25b82acb9-6648-1601
Correlation-ID: 8f0317ff-104e-4fff-a6e7-c7f028a96aa7
X-Powered-By: ASP.NET
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
Content-Security-Policy: default-src 'self'; script-src 'self' 'unsafe-inline'; style-src 'self' 'unsafe-inline';
X-Global-Transaction-ID: 1419771149
X-APP-STATUS: 404
Strict-Transport-Security: max-age=2592000;includeSubdomains
Date: Tue, 28 May 2019 11:17:31 GMT
Connection: close
5. Response Body

{
"resource": {"debitCards": null},
"processingTimeInMs": 16,
"receivedTimestamp": "2019-05-28 11:17:31.106",
"errors": ["No Cards Found"]
}

 

 

404 Error codes for this API

404-Not Found: The account could not be found
404-Routing number to Institution ID mapping Failure
404-No Cards tied to Account
404-No Active Cards found
404-No Cards found