Visa Developer Community

Regular Visitor

Firefox ignores turned off autocompleting.

Hi,

I have a strange problem with login form o Firefox (tested version 49.0.1 on Windows and 48.0 on Ubuntu).
When I click the Visa Checkout button, login form appears. The password field should be empty (it has autocomplete="new-password" attribute). But Firefox ignores that and autocompletes that field.

When I click "Sign In to Visa Checkout" I'm getting an error "Please enter your sign-in credentials". But when I click the button one more time everything is ok.

Seems like Firefox is filling the password field but login form doesn't see it. If I click on password field and then on the button, everything is ok too (looks like when I click the password field, javascript sees that field as edited by user and performs validation).

Maybe you shuld turn off checking whether the field has been clicked? Or maybe is there another way to turn off autocompleting for Firefox?

 

1 REPLY 1
Community Manager

Re: Firefox ignores turned off autocompleting.

Hi there,

 

Seems like it might be more of a Firefox configuration issue and not sure we can support. I will continue to check on you. 

 

Thank you,

Ricardo

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.