Visa Developer Community

Highlighted
Newbie

Testing Production in the simulator

Hi,

 

I have an iOS project that is already in production using VisaCheckoutSDK so everything is integrated and working.

I was trying to run some tests using xcode's simulators and I am getting this error:

 

** VisaCheckoutSDK Configuration Error **

Debug mode is not supported for production environments. Visa Checkout will not be able to launch.

 

My question is, is this behaviour expected? I can only test production using a real device? If not I would apreciate some help to fix this.

 

Thanks

2 REPLIES 2
Highlighted
Visa Dev Moderator

Re: Testing Production in the simulator

Hi @kmaeda

 

Can you confirm if you have updgraded to the latest version of iOS SDK? 

 

We have an expert team that manages questions specific to the Visa Checkout product. Please submit this inquiry to Developer@visa.com and someone will connect you to the expert team soon!

 

Thank you, 

Vaibhav 

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.
Highlighted
Visa Dev Moderator

Re: Testing Production in the simulator

Hey @kmaeda,

 

Are you still experiencing an error with Visa Checkout?

 

To further investigate, please provide the following information:

1. End Point
2. Request Header
3. Request Body
4. Response Header (include the x-correlation-id)
5. Response Body

Using SoapUI, you can find the x-correlation-id in the Raw Tab of the response header.

 



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

Thanks,
Diana