asaldanha
New Contributor

VTC Registration acting flaky

Yesterday this call to 

vctc/customerrules/v1/consumertransactioncontrols was working fine (07/15/2021)

 

Today its returning bad request (header and correlation ID below)

 

I am using the same code structure as calling PushFundsTransactions in your sample code - except changing the endpoint and the JSON

(code below).

 

PushFundsTransactions continues to work, but trying to enroll a card is not.

 

 

 


response.StatusCode = BadRequest

response.Headers =
Server: nginx
Date: Fri, 16 Jul 2021 15:12:18 GMT
Connection: keep-alive
X-SERVED-BY: l55c017
X-CORRELATION-ID: 1626448338_305_1395579264_l55c017_VDP_WS
X-APP-STATUS: 500
X-Backside-Transport: FAIL FAIL,FAIL FAIL
X-Global-Transaction-ID: 1adcbd1660f1a1d20a140b49
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
Strict-Transport-Security: max-age=2592000;includeSubdomains
Cache-Control: no-store, must-revalidate, no-cache
Pragma: no-cache
X-Cnection: close, close
Content-Type: application/json; charset=UTF-8
Content-Length: 141
Expires: -1
Content-Language: en-US


response.Body = (blank)

 

 

public string PushFundsTransactions()
{
string localTransactionDateTime = DateTime.Now.ToString("yyyy-MM-dd'T'HH:mm:ss");
string requestBody = "{ \"acquirerCountryCode\": \"840\", \"acquiringBin\": \"408999\", \"amount\": \"124.05\", \"businessApplicationId\": \"AA\", \"cardAcceptor\": { \"address\": { \"country\": \"USA\", \"county\": \"San Mateo\", \"state\": \"CA\", \"zipCode\": \"94404\" }, \"idCode\": \"CA-IDCode-77765\", \"name\": \"Visa Inc. USA-Foster City\", \"terminalId\": \"TID-9999\" }, \"localTransactionDateTime\": \"" + localTransactionDateTime + "\", \"merchantCategoryCode\": \"6012\", \"pointOfServiceData\": { \"motoECIIndicator\": \"0\", \"panEntryMode\": \"90\", \"posConditionCode\": \"00\" }, \"recipientName\": \"rohan\", \"recipientPrimaryAccountNumber\": \"4957030420210462\", \"retrievalReferenceNumber\": \"412770451018\", \"senderAccountNumber\": \"4957030420210454\", \"senderAddress\": \"901 Metro Center Blvd\", \"senderCity\": \"Foster City\", \"senderCountryCode\": \"124\", \"senderName\": \"Mohammed Qasim\", \"senderReference\": \"\", \"senderStateCode\": \"CA\", \"sourceOfFundsCode\": \"05\", \"systemsTraceAuditNumber\": \"451018\", \"transactionCurrencyCode\": \"USD\", \"transactionIdentifier\": \"381228649430015\" }";

string requestURL = "visadirect/fundstransfer/v1/pushfundstransactions";

return GetDecryptedPayload(DoMutualAuthCall(requestURL, "POST", "OCT With MLE", getEncryptedPayload(requestBody), null));
}

public string EnrollCardTransactions()
{
string localTransactionDateTime = DateTime.Now.ToString("yyyy-MM-dd'T'HH:mm:ss");
string requestBody = "{ \"primaryAccountNumber\": \"4514170000000001\" }";

//string requestURL = "visadirect/fundstransfer/v1/pushfundstransactions";
string requestURL = "vctc/customerrules/v1/consumertransactioncontrols";

return GetDecryptedPayload(DoMutualAuthCall(requestURL, "POST", "OCT With MLE", getEncryptedPayload(requestBody), null));
}

 

 

3 REPLIES 3
SLi
Visa Dev Moderator
Visa Dev Moderator

Re: VTC Registration acting flaky

Hi @asaldanha,

 

Can you please share the request payload and response body? Are you encrypting the payload? MLE is optional for this endpoint, did you try without encryption?


Best,
Stacey

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.
asaldanha
New Contributor

Re: VTC Registration acting flaky

No idea what was happening on your side - but after a 30-45 mins of getting errors it started responding as expected

SLi
Visa Dev Moderator
Visa Dev Moderator

Re: VTC Registration acting flaky

Hi @asaldanha,

 

Thanks for letting us know that you are getting valid responses from the API.


Best,
Stacey

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.