api connection problem

Solved! Go to solution
sandeep1
New Contributor

api connection problem

Hi
i am getting some content similar to (Failed to establish a backside connection
) in response.But before some time it was working properly.Please provide me the solution about this problem

thanks

9 REPLIES 9
Rossman
Regular Visitor

Re: api connection problem

Have a same problem. 500 error, seems server trouble.

DianaTran-Yee
Visa Developer Support Specialist

Re: api connection problem

Hey @Rossman and @sandeep1,

 

I'm happy to help resolve the issue. If the issue persists, please provide the following information below for further assistance and let us know of any questions.
 
Below are the steps to get the Correlation ID using a Google Chrome browser.
1>Open Chrome menu.
2>Click on More tools then Developer tools.
3>Check the box to Preserve Log for the Network Tab.
4>Click on the error and go to the Headers.
5>You can find the Correlation ID in the network log.

 




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

sandeep1
New Contributor

Re: api connection problem

actually i am getting the response
{
"statusCode": 500,
"body": "\n<message>\n<response-code/>\n<error-message>Failed to establish a backside connection</error-message></message>",
"headers": {
"server": "nginx",
"date": "Thu, 05 Nov 2020 05:07:34 GMT",
"content-type": "text/xml",
"content-length": "110",
"connection": "close",
"x-served-by": "l55c014",
"x-correlation-id": "1604552854_715_1942501529_l55c014_VDP_WS",
"x-backside-transport": "FAIL FAIL",
"x-app-status": "500",
"x-frame-options": "SAMEORIGIN",
"x-xss-protection": "1; mode=block",
"x-content-type-options": "nosniff",
"strict-transport-security": "max-age=2592000;includeSubdomains",
"cache-control": "no-cache, no-store, must-revalidate",
"pragma": "no-cache",
"expires": "-1",
"x-cnection": "close"
},
"request": {
"uri": {
"protocol": "https:",
"slashes": true,
"auth": null,
"host": "sandbox.api.visa.com",
"port": 443,
"hostname": "sandbox.api.visa.com",
"hash": null,
"search": null,
"query": null,
"pathname": "/vmorc/offers/v1/byfilter",
"path": "/vmorc/offers/v1/byfilter",
"href": "https://sandbox.api.visa.com/vmorc/offers/v1/byfilter"
},
"method": "GET",
"headers": {
"Content-Type": "application/json",
"Accept": "application/json",
"Authorization": "Basic VFFBWVIyQVNTWFEwSk1VNzkwOEYyMWptbjhQZTZzYzktaWlhXzRZclNXTUJzYmY2WTo2QjQzS1E2NDdLNUdIZnk0U1VKOFU2MzR0N1cwQ3JKN2dxU1Jy"
}
}

sandeep1
New Contributor

Re: api connection problem

where to pass this x-correlation-id for getting the data from api

"x-correlation-id": "1604552854_715_1942501529_l55c014_VDP_WS",

sandeep1
New Contributor

Re: api connection problem

i have paas
"x-correlation-id": "B66PI6SIT3GX_SC"
in header but it return same as previous.
{
"statusCode": 500,
"body": "\n<message>\n<response-code/>\n<error-message>Failed to establish a backside connection</error-message></message>",
"headers": {
"server": "nginx",
"date": "Fri, 06 Nov 2020 09:31:19 GMT",
"content-type": "text/xml",
"content-length": "110",
"connection": "close",
"x-served-by": "l73c012",
"x-correlation-id": "1604655079_283_170689103_l73c012_VDP_WS",
"x-backside-transport": "FAIL FAIL",
"x-app-status": "500",
"x-frame-options": "SAMEORIGIN",
"x-xss-protection": "1; mode=block",
"x-content-type-options": "nosniff",
"strict-transport-security": "max-age=2592000;includeSubdomains",
"cache-control": "no-cache, no-store, must-revalidate",
"pragma": "no-cache",
"expires": "-1",
"x-cnection": "close"
},
"request": {
"uri": {
"protocol": "https:",
"slashes": true,
"auth": null,
"host": "sandbox.api.visa.com",
"port": 443,
"hostname": "sandbox.api.visa.com",
"hash": null,
"search": null,
"query": null,
"pathname": "/vmorc/offers/v1/all",
"path": "/vmorc/offers/v1/all",
"href": "https://sandbox.api.visa.com/vmorc/offers/v1/all"
},
"method": "GET",
"headers": {
"Content-Type": "application/json",
"Accept": "application/json",
"User-Agent": "VDP_SampleCode_Nodejs",
"Authorization": "Basic VFFBWVIyQVNTWFEwSk1VNzkwOEYyMWptbjhQZTZzYzktaWlhXzRZclNXTUJzYmY2WTo2QjQzS1E2NDdLNUdIZnk0U1VKOFU2MzR0N1cwQ3JKN2dxU1Jy",
"x-correlation-id": "B66PI6SIT3GX_SC",
"x-client-transaction-id": "05LONYTIZY32"
}
}
}

sandeep1
New Contributor

Re: api connection problem

Please check what is the problem with this i have pass all required prams in header but i am getting the same (Failed to establish a backside connection). i have invest so much time with this problem.

{
"statusCode": 500,
"body": "\n<message>\n<response-code/>\n<error-message>Failed to establish a backside connection</error-message></message>",
"headers": {
"server": "nginx",
"date": "Fri, 06 Nov 2020 09:31:19 GMT",
"content-type": "text/xml",
"content-length": "110",
"connection": "close",
"x-served-by": "l73c012",
"x-correlation-id": "1604655079_283_170689103_l73c012_VDP_WS",
"x-backside-transport": "FAIL FAIL",
"x-app-status": "500",
"x-frame-options": "SAMEORIGIN",
"x-xss-protection": "1; mode=block",
"x-content-type-options": "nosniff",
"strict-transport-security": "max-age=2592000;includeSubdomains",
"cache-control": "no-cache, no-store, must-revalidate",
"pragma": "no-cache",
"expires": "-1",
"x-cnection": "close"
},
"request": {
"uri": {
"protocol": "https:",
"slashes": true,
"auth": null,
"host": "sandbox.api.visa.com",
"port": 443,
"hostname": "sandbox.api.visa.com",
"hash": null,
"search": null,
"query": null,
"pathname": "/vmorc/offers/v1/all",
"path": "/vmorc/offers/v1/all",
"href": "https://sandbox.api.visa.com/vmorc/offers/v1/all"
},
"method": "GET",
"headers": {
"Content-Type": "application/json",
"Accept": "application/json",
"User-Agent": "VDP_SampleCode_Nodejs",
"Authorization": "Basic VFFBWVIyQVNTWFEwSk1VNzkwOEYyMWptbjhQZTZzYzktaWlhXzRZclNXTUJzYmY2WTo2QjQzS1E2NDdLNUdIZnk0U1VKOFU2MzR0N1cwQ3JKN2dxU1Jy",
"x-correlation-id": "B66PI6SIT3GX_SC",
"x-client-transaction-id": "05LONYTIZY32"
}
}
}

DianaTran-Yee
Visa Developer Support Specialist

Re: api connection problem

Hey @sandeep1  and @Rossman,

 

I'd like to help resolve the issue. The Visa Merchant Offers Resource Center API update is currently in pending status, and will hopefully be resolved by November 23rd or sometime next week. Once the update is complete, please test again and share your test results with us and let us know if you have questions. Someone will be happy to help.




Thanks,

Diana



Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.

sandeep1
New Contributor

Re: api connection problem

Thank you
now it is working

Thanks
Sandeep

sandeep1
New Contributor

Re: api connection problem

(I'd like to help resolve the issue. The Visa Merchant Offers Resource Center API update is currently in pending status, and will hopefully be resolved by November 23rd or sometime next week.)
Thanks once again now it is working.

--------------------

hare is the response :

{ "ReturnedResults": 13, "StartIndex": 1, "Offers": [ { "indexNumber": 1, "offerContentId": 105513, "offerId": 102357, "currentVersion": 1,
---------------

Thanks

sandeep