Test Question

Regular Visitor

Test Question

Hi, I have some issues with x-pay-token while trying to "GenerateKey" in Secure Acceptance Flexible Token API. I have tried many times but seems like it's not getting better.  What I tried are:

1. Using sample code from documentation page to generate x-pay-token.

2. The request info:


  • resource_path: payments/flex/v1/keys
  • query_string:  apikey=myAppKey
  • request_body: "\"encryptionType\": \"RsaOaep256\""

 3. My generated x-pay-token looks like xv2:1526354851:ee3292d8818536c3ba231e1c425ae7dc340e4edbc218eb362f81106d0387d115

4. I'm using postman to make a request.

Here's the response that I always receive:


    "responseStatus": {
        "code": "9102",
        "severity": "ERROR",
        "info": "",
        "status": 401,
        "message": "Token validation failed"

 I really have no idea what was wrong for my request. Please help me to feature out. Thanks in advance.

Visa Developer Support Specialist

Re: Test Question

Hi @hicurin,


If you are a developer testing on v1 CyberSource APIs then this version was recently deprecated. You will need to move to v2 CyberSource APIs going forward. 




Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.