Visa Developer Community

Regular Visitor

Invalid PAN when making a PullFunds request

I'm having some trouble getting the PullFundsTransaction to work. Any ideas on what might be going wrong would be extremely helpful.

 

I have also noticed that the cards provided as test data are not valid card numbers in that they do not pass the Luhn check. I have tried with both the numbers provided in the test data, and other valid card numbers, but neither seem to work.

What is particularly unusual is that both of these card numbers work just fine with the PushFundsTransaction.

 

Request with valid card:

{
  "acquirerCountryCode": "554",
  "acquiringBin": 409999,
  "senderCurrencyCode": "NZD",
  "surcharge": "0.50",
  "amount": "16.69",
  "businessApplicationId": "AA",
  "senderPrimaryAccountNumber": "4987654321098769",
  "systemsTraceAuditNumber": "000036",
  "cardAcceptor": {
    "terminalId": "13655392",
    "idCode": "VMT200911026070",
    "address": {
      "country": "NZL"
    },
    "name": "John Smith"
  },
  "senderCardExpiryDate": "2017-05",
  "localTransactionDateTime": "2016-12-27T10:35:56",
  "retrievalReferenceNumber": "636210000036"
}

Request with "test data" card:

{
"acquirerCountryCode": "554",
"acquiringBin": 409999,
"senderCurrencyCode": "NZD",
"surcharge": "0.50",
"amount": "16.69",
"businessApplicationId": "AA",
"senderPrimaryAccountNumber": "4957031034658008",
"systemsTraceAuditNumber": "000037",
"cardAcceptor": {
"terminalId": "13655392",
"idCode": "VMT200911026070",
"address": {
"country": "NZL"
},
"name": "John Smith"
},
"senderCardExpiryDate": "2017-05",
"localTransactionDateTime": "2016-12-27T10:38:47",
"retrievalReferenceNumber": "636210000037"
}

Both requests result in the same error message:

{\n "errorMessage" : "API Validation Error: 3001. Invalid PAN."\n}

 

2 REPLIES 2
Regular Visitor

Re: Invalid PAN when making a PullFunds request

On using the same PAN as that in the example on the PullFundsTransactions POST page, the request succeeds. Still wont work with the "test data" cards though.
Community Manager

Re: Invalid PAN when making a PullFunds request

Hi there, 

 

By the looks of it, from the below payload it seems like the you are using Invalid PAN to do the Pull Funds Transaction. Why don't you try the PAN number from scenarios like for example “Action Code – 00” .

 

Also it would try addng the following fields in the below highlighted payload:

 

      "county": "San Mateo",

      "state": "CA",

      "zipCode": "94404"

 

Let me know if this helps.

 

Thank you,

Ricardo 

 




Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.