error '"Expected input credential was not present"'

SOLVED
Elvira
New Contributor

error '"Expected input credential was not present"'

Hi!

During the testing in the sandbox 2-way SSL connection is successfully established, but MLE is not passed. 

The request and response messages are below. X-CORRELATION-ID=1629883023_658_671536407_l55c018_VDP_WS

 

Request headers:

{Authorization=[Basic QTkyN01CR09UOERJTVhFSVRMVjcyMTNBYTVHTkxGZGZRYV9keFJQek1BMHRYZWZjZzpFUnA1MTl6NDdmNURCUGxQZkRqOWhrZE0y], keyId=[f7e6ee41-2440-43a2-ae37-2bb21d852d31]}

 

Request Message (PAN and alias are masked here):
{"country":"RU","recipientLastName":"Ш.","recipientFirstName":"АНАТОЛИЙ","recipientPrimaryAccountNumber":"4242**7512","issuerName":"BANK_URALSIB","cardType":"Visa Rewards","consentDateTime":"2021-08-25 09:17:01","expiryDate":"2024-06","aliasType":"01","guid":"45187130","alias":"7961**710"}

 

Response headers:

Server=nginx, Date=Wed, 25 Aug 2021 09:17:03 GMT, Content-Type=application/json, Content-Length=130, Connection=close, X-SERVED-BY=l55c018, X-CORRELATION-ID=1629883023_658_671536407_l55c018_VDP_WS, x-vdp-normalized-url=/visaaliasdirectory/v1/manage/createalias, X-APP-STATUS=400, x-vdp-authn-api-visa-id=ALIAS.100, X-Frame-Options=SAMEORIGIN, X-XSS-Protection=1; mode=block, X-Content-Type-Options=nosniff, Strict-Transport-Security=max-age=31536000;includeSubdomains, Cache-Control=no-cache, no-store, must-revalidate, Pragma=no-cache, Expires=-1, channel: [id: 0x919a4b62, L:/10.166.138.204:44652 - R:sandbox.api.visa.com/198.241.194.217:443]

 

Response message:

{"responseStatus":{"status":400,"code":"9123","severity":"ERROR","message":"Expected input credential was not present","info":""}}

 

Could you please check where is the problem?

1 REPLY 1
SLi
Visa Developer Support Specialist
Visa Developer Support Specialist

Re: error '"Expected input credential was not present"'

Hi @Elvira,

 

The error "Expected input credential was not present" usually occurs when the credentials used are invalid. The error code 9123 typically means that basic authentication is not sent in the header with user name and password base64 encoded. Please ensure that "Content-Type: application/json" is in the request Header and Authorization Header has the "Basic" prefix. If you are using Soap UI, please check File->Settings->SSL Settings and make sure the KeyStore and KeyStore Password are populated in Soap UI.

 

We have a few Visa Alias Directory tutorials, please feel free to check it out here:

https://community.developer.visa.com/t5/Tutorials/Tutorials-Visa-Alias-Directory-Service/ba-p/18435 

 

Hope this helps, please reach back out if you have any questions.

 

 


Best,
Stacey

Was your question answered? Don't forget to click on "Accept as Solution" to help other devs find the answer to the same question.